Jump to content


Photo

export suddenly fails silently


  • Please log in to reply
3 replies to this topic

#1 Mikael B

Mikael B

    Fireworks Sparkle

  • Members
  • Pip
  • 3 posts

Posted 22 June 2011 - 12:25 PM

An export from a one page file with only a few layers, suddenly silently results in no files created at all. No error messages in FW. Only a few hours ago exports worked fine again after I had deleted the prefs and made a new file.
It doesn't matter if I uncheck or check everything in the export dialog, have one slice selected and right click to "export selected slice" or if I select one or several and use the menu option, Fireworks CS4 10.0.4.1 just will not export anything from any file.

This have been my experience for years, but never this bad. Are there any known work-arounds for this problem?
While I can move to Photoshop, I must work on my Pngs after I export from there and it's a pain.

Do any of you more experienced with FW have some suggestions on how to shake FW enough to make exports work again?

In Console I've had this repeating message, but it's been going all the time, so it's not related in time, at least:
"2011-06-22 20.34.09 Adobe Fireworks CS4[12911] Adobe Fireworks CS4(12911,0xa09ca820) malloc: *** error for object 0xffffffff: Non-aligned pointer being freed
*** set a breakpoint in malloc_error_break to debug"
AND:
"2011-06-22 14.09.16 Adobe Fireworks CS4[10719] *** _NSAutoreleaseNoPool(): Object 0x9613c40 of class NSCFArray autoreleased with no pool in place - just leaking"





FW 10.0.4.1 on Mac OS X 10.5.8 (PPC).

#2 DaveH

DaveH

    FireworksNut

  • Members
  • PipPipPipPipPipPip
  • 343 posts
  • Location:San Francisco CA USA

Posted 22 June 2011 - 02:04 PM

Ack, that's a bad error. You can report it here:

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Include the error console info, too. The more detailed info you can provide, the better.

I've had an occasional bug where a file suddenly stops exporting after having exported successfully before, but it has corrected itself after re-starting FW. Do other files export correctly? Is it only this file?

It is possible for a FW PNG file to become corrupted - sometimes it can be recovered by opening and copying the contents into a new FW document. If other files are exporting correctly and only this file fails, I would create a new FW document and start to copy over the contents one page at a time, checking to make sure the new file exports properly. If the new file starts to fail after copying something, you have found the cause of the corruption, and that page will need to be re-created in a new FW document.

Dave

#3 Mikael B

Mikael B

    Fireworks Sparkle

  • Members
  • Pip
  • 3 posts

Posted 22 June 2011 - 02:52 PM

Ack, that's a bad error.

I've had an occasional bug where a file suddenly stops exporting after having exported successfully before, but it has corrected itself after re-starting FW. Do other files export correctly? Is it only this file?

It is possible for a FW PNG file to become corrupted - sometimes it can be recovered by opening and copying the contents into a new FW document. If other files are exporting correctly and only this file fails, I would create a new FW document and start to copy over the contents one page at a time, checking to make sure the new file exports properly. If the new file starts to fail after copying something, you have found the cause of the corruption, and that page will need to be re-created in a new FW document.

Dave


It seems to be every file, but if I go back I may be able to find a file that does work.

I have had repeated crashes when selecting more than one layer in the layer panel — I assume this is a known bug as it happens every time —, so I suppose it's possible those crashes could have corrupted the files I've been working on. If so, Fireworks must be the only app I use that corrupt the open file when crashing. Maybe it's trying to write to the file at the time.

I did what you suggested already before and export worked for every slice and then it stopped working again.

Thanks for your response.

#4 Mikael B

Mikael B

    Fireworks Sparkle

  • Members
  • Pip
  • 3 posts

Posted 02 July 2011 - 08:05 AM

It seems to be every file, but if I go back I may be able to find a file that does work.

I have had repeated crashes when selecting more than one layer in the layer panel — I assume this is a known bug as it happens every time —, so I suppose it's possible those crashes could have corrupted the files I've been working on


Update: I made a new file and recreated all graphics saving a new version for every step. If I did have a crash with the file open I got back to the previous version. Exporting seems to be working as expected in the file that never crashed. So making sure you have an uncrashed source file prevents this export error. That Fireworks is silently corrupting the source file is IMHO a very very bad behavior.