Jump to content


Photo

Flash Panel previews in Flash, but won't load in Fireworks


  • Please log in to reply
2 replies to this topic

#1 mitya777

mitya777

    FireStarter

  • Members
  • PipPip
  • 28 posts

Posted 13 June 2011 - 06:53 AM

Hello,

I have a .fla file that when you 'preview movie' in Flash loads and looks like it works, but when I export it to Fireworks it loads an empty window with 4 flashing dots in the middle. Does anyone have any input for what might be causing something like this? Or how I might go about getting some feedback from Fireworks as to what is causing the problem? Otherwise I have to resort to just deleting parts of the panel and reloading it until I figure it out by process of elimination. Has anyone come across this?

Thank you for all your help.

#2 jdunning

jdunning

    Fireworks Ninja

  • Members
  • PipPipPipPipPip
  • 173 posts

Posted 13 June 2011 - 12:17 PM

Hello,

I have a .fla file that when you 'preview movie' in Flash loads and looks like it works, but when I export it to Fireworks it loads an empty window with 4 flashing dots in the middle. Does anyone have any input for what might be causing something like this? Or how I might go about getting some feedback from Fireworks as to what is causing the problem? Otherwise I have to resort to just deleting parts of the panel and reloading it until I figure it out by process of elimination. Has anyone come across this?

I only create Flash panels in Flex these days, so I'm not sure what the process is in Flash. When you say export, you mean create a .swf? Do the flashing dots look like a loader of some kind?

With the Fireworks Console, you can also dump values from AS3 to the console, by importing the com.johndunning.fw.console library and then calling console.log(). There's a console.swc file that comes with the extension which you can add to your project. (Not sure how to do it in Flash, though.) The extension's page has a little more info at the end: http://johndunning.c...about/FWConsole

Using log calls early in your movie might help you determine where things are breaking.

#3 mitya777

mitya777

    FireStarter

  • Members
  • PipPip
  • 28 posts

Posted 14 June 2011 - 05:59 AM

Hey John, yes, when I say export I mean save a .swf in the command panel folder in Fireworks. The problem is that when I preview the panel in Flash, everything works as it should. But when I save the swf in Fireworks and open it there I get an empty panel with animated dots in the middle as though it is loading. But I don't get any kind of feedback as to what the problem is. I will try to see if some console output makes it through but I fear that the panel is not even loading.

If that doesn't work I will have to give Flex a shot.