Jump to content


Photo

Is it a Bug? Integration between DW and FW is broken in somewhere?


  • Please log in to reply
5 replies to this topic

#1 mrtvrl

mrtvrl

    Fireworks Sparkle

  • Members
  • Pip
  • 0 posts

Posted 29 September 2008 - 11:45 PM

I use CS3 Suite. It is a big trouble for me in working on real pages. Integration is broken in somewhere else and after that point it becomes impossible to work on Fireworks through Dreamweaver.

I've made test to show this trouble and I narrowed the problem to the pictures as shown in the figures below,

1) In figure one I am creating a completely new Fireworks file as arrow.png with two frames and one slice in it. After I am saving it as .png I am exporting it as .html with images in /images subfolder.

2) After saving and closing the file in Fireworks, in figure two, I am opening the html in Dreamweaver and changing the page properties by writing zeros to page margins and by changing the default font.

-----I guess in this point something happens which breaks the integration between FW and DW--------because;

3) In figure three I am opening the .png through Dreamweaver (by "Edit") and changes the place and size of the slice a little bit

4) When I press Done in Fireworks I see this picture in figure four in Dreamweaver which shows integration between FW and DW about table structure is broken. (In this point if I add any behaviur to the slice DW doesn't recognize it, or any other change in FW can not be recognized by DW)

5) In order to show this broken integration in table sturucture, I am putting a new slice to png when Editing from DW in FW.

6) When I click on Done in DW I see this picture on the figure six. Beacuse FW doesn't have any effect on html's table structure code.


Do anyone have information about this situation? Is it a bug or am I doing something wrong?

Attached Images

  • 1.gif
  • 2.gif
  • 3.gif
  • 4.gif
  • 5.gif
  • 6.gif


#2 mrtvrl

mrtvrl

    Fireworks Sparkle

  • Members
  • Pip
  • 0 posts

Posted 30 September 2008 - 10:25 AM

I see so many visitors but there is no reply. I would appreciate if visitors of subject can write if they experienced this kind of problem or not. Or if you can make the same test with first 4 steps in your computer that will be a great clue to solve the mystery. (you can email if you prefer to "vural.mrt@gmail.com")

#3 Alan

Alan

    FireworksGuru

  • Root Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,506 posts
  • Location:San Francisco, California USA
  • Interests:Longboarding, art and video games

Posted 04 October 2008 - 08:30 AM

hey mrtvrl -

I just tried the same steps and not able to reproduce the problem you are describing. Just to make sure I got this straight:

1. Create a document with rollovers
2. Export to HTML/Images
3. Change the table margins to 0
4. Roundtrip the table with the Fw source PNG
5. Observe slices, make a change to the color of the rollover just to see a change in the roundtrip

Is this right, sorry for not getting you the first time or maybe I did and not able to see it??

Welcome to Fwguru btw! :)

#4 mrtvrl

mrtvrl

    Fireworks Sparkle

  • Members
  • Pip
  • 0 posts

Posted 04 October 2008 - 11:12 PM

hey mrtvrl -

I just tried the same steps and not able to reproduce the problem you are describing. Just to make sure I got this straight:

1. Create a document with rollovers
2. Export to HTML/Images
3. Change the table margins to 0
4. Roundtrip the table with the Fw source PNG
5. Observe slices, make a change to the color of the rollover just to see a change in the roundtrip

Is this right, sorry for not getting you the first time or maybe I did and not able to see it??

Welcome to Fwguru btw! :)


Thank you for "welcome"

Just two questions,
-Did you save the document within DW after step 3?
-I couldn't understand exactly step 5. Did you make a change in size and/or place of the existing Slice?

#5 mrtvrl

mrtvrl

    Fireworks Sparkle

  • Members
  • Pip
  • 0 posts

Posted 17 October 2008 - 05:40 AM

Thank you for "welcome"

Just two questions,
-Did you save the document within DW after step 3?
-I couldn't understand exactly step 5. Did you make a change in size and/or place of the existing Slice?



Still waiting an answer, it is important!

#6 mrtvrl

mrtvrl

    Fireworks Sparkle

  • Members
  • Pip
  • 0 posts

Posted 17 October 2008 - 11:31 PM

I have a general question which is not directly releated with my topic here (it is releated a little bit because I could not have a conversation with people here)

My question is :

When I look to topics list I see every topic has THOUSANDS of views but only 1 or 2 (sometimes several) replies. Why people don't speak in this forum?

Forum means "to share" and in other forums on the net, people talks each other a lot. But here, people has a high unwillingness to say something (not for just my topic, it seems for every topic). Here is like a "read only" forum.

The only answer which I found is visitors are coming from outside (not forum members) and they make thousands of "views". But they can not "reply" And there are a little number of forum members because of rejecting new sign-ups, so replies are very few.

This is only my theory, I don't know the real reason of why peaople is not speaking here, but I really wonder.